Back to overview
Resolved
Degraded API Performance
Jul 7, 2026 at 5:55pm UTC
Affected services
API
Resolved
Jul 7, 2026 at 6:20pm UTC
We're seeing recovery, and latency and error rates have returned to normal levels. We'll continue to monitor closely.
Affected services
Created
Jul 7, 2026 at 5:55pm UTC
We're observing widespread elevated latency and increased error rates across our APIs. We're actively looking into it.
Affected services