Back to overview
Resolved

Elevated Latency and Error Rates Across APIs

Jul 7, 2026 at 8:35am UTC
Affected services
API

Resolved
Jul 7, 2026 at 10:05am UTC

We're seeing recovery, and latency and error rates have returned to normal levels. We'll continue to monitor closely.

Created
Jul 7, 2026 at 8:35am UTC

We're observing elevated latency and an increased error rate across our APIs. We're actively looking into it.