Back to overview
Resolved
Degraded performance Google Scholar
Jul 6, 2026 at 12:30pm UTC
Affected services
API
Resolved
Jul 6, 2026 at 4:39pm UTC
Google Scholar performance has returned to normal. Latency and success rates have recovered to their normal levels, and the upstream issue appears to have been resolved.
Affected services
Created
Jul 6, 2026 at 12:30pm UTC
We're observing elevated latency and an increased failure rate for Google Scholar requests. The issue appears to be upstream with Google Scholar. We're monitoring the situation.
Affected services