Back to overview
Degraded

Partial outage

May 15, 2026 at 7:17pm UTC
Affected services
API

Resolved
May 15, 2026 at 7:55pm UTC

Latency has returned to normal levels. We’ll continue monitoring closely to ensure stability.

Created
May 15, 2026 at 7:17pm UTC

We're currently experiencing a partial outage causing increased latency for some queries. Our team is actively working on recovery and monitoring the situation closely.