Back to overview
Degraded
Degradation of /images endpoint
Mar 3, 2026 at 12:53am UTC
Affected services
API
Resolved
Mar 3, 2026 at 1:46am UTC
Performance is back to normal again.
Affected services
Updated
Mar 3, 2026 at 1:16am UTC
We have applied an initial fix.
Affected services
Created
Mar 3, 2026 at 12:53am UTC
Google just made a change to Google Images impacting a subset of /images queries. We're looking into it.
Affected services