Back to overview
Degraded
Increase in timeouts Google Search
Feb 22 at 08:20am GMT
Affected services
API
Resolved
Feb 22 at 05:30pm GMT
Latency for the affected queries has come back down and things appear to have recovered.
Affected services
Created
Feb 22 at 08:20am GMT
We’re observing spikes in timeouts on Google Search again, resulting in increased latency for a subset of queries.
Affected services