Back to overview
Degraded

Increase in timeouts Google Search

Feb 22 at 05:50am GMT
Affected services
API

Resolved
Feb 22 at 06:40am GMT

It seems to be recovering.

Created
Feb 22 at 05:50am GMT

We're observing an increase in timeouts for Google Search.