Back to overview
Resolved

Elevated Latency and Error Rates Across APIs

Sep 10, 2026 at 1:39pm UTC
Affected services
API

Resolved
Sep 10, 2026 at 2:45pm UTC

We're seeing initial recovery

Created
Sep 10, 2026 at 1:39pm UTC

We're observing elevated latency and an increased error rate across our APIs. We're actively looking into it.