Back to overview
Resolved

Elevated Latency Across APIs

Sep 1, 2026 at 3:34pm UTC
Affected services
API

Resolved
Sep 1, 2026 at 5:22pm UTC

We're seeing recovery

Created
Sep 1, 2026 at 3:34pm UTC

It seems Google itself is having infra issues at the moment causing higher latencies across all endpoints: https://downdetector.com/status/google/
https://status.cloud.google.com/