Back to overview
Degraded
Elevated Latency and Error Rates Across APIs
Aug 7, 2026 at 5:39pm UTC
Affected services
API
Updated
Aug 8, 2026 at 11:12am UTC
Repeated non-generic queries sent within a short time window are seeing higher latency due to changes by Google.
Affected services
Updated
Aug 8, 2026 at 5:40am UTC
The error rate seems to have recovered to normal levels. We’re still observing higher latency for a subset of queries.
Affected services
Created
Aug 7, 2026 at 5:39pm UTC
We're observing elevated latency and an increased error rate across our APIs. We're actively looking into it.
Affected services